To all our customers that use Wordpress on their hosting account. 

WordPress versions prior to 4.7.5 are affected by multiple vulnerabilities. A remote attacker could exploit some of these vulnerabilities to take control of an affected website.

Users and administrators are encouraged to review the WordPress Releases Security update and upgrade to WordPress 4.7.5.



Thursday, May 18, 2017







« Back